SMSC returned error code 0x00000436

Alejandro Guerrieri aguerrieri at kannel.org
Mon Oct 18 11:11:16 CEST 2010


"Vendor-specific error, please refer to your SMPP provider"

Did you find the error on SMPP spec 3.4? NO.
Did you find anything about it on Google? NO.
Did anyone confirm that this is from vendor side? Yes, I did.

Enough said... the vendor could have used that error to map whatever he wanted it to be. You need to ask him, not us.
--
Alejandro Guerrieri
aguerrieri at kannel.org



On 18/10/2010, at 11:06, Saeed Ashour wrote:

> Greetings,
> 
> it happens when I'm trying to submit sms using sendsms.php
> 
> and here is part of bearbox.log
> 
> 2010-10-18 11:06:13 [6827] [6] ERROR: SMPP[SMPP:*:5019/5019:mail:test]: SMSC returned error code 0x00000436 (Vendor-specific error, please refer to your SMPP provider) in response to submit_sm.
> 2010-10-18 11:06:20 [6827] [6] DEBUG: SMPP[SMPP:*:5019/5019:mail:test]: Sending enquire link:
> 2010-10-18 11:06:20 [6827] [6] DEBUG: SMPP PDU 0x99a76f0 dump:
> 2010-10-18 11:06:20 [6827] [6] DEBUG:   type_name: enquire_link
> 2010-10-18 11:06:20 [6827] [6] DEBUG:   command_id: 21 = 0x00000015
> 2010-10-18 11:06:20 [6827] [6] DEBUG:   command_status: 0 = 0x00000000
> 2010-10-18 11:06:20 [6827] [6] DEBUG:   sequence_number: 1867 = 0x0000074b
> 2010-10-18 11:06:20 [6827] [6] DEBUG: SMPP PDU dump ends.
> 2010-10-18 11:06:20 [6827] [6] DEBUG: SMPP[SMPP:*:5019/5019:mail:test]: Got PDU:
> 2010-10-18 11:06:20 [6827] [6] DEBUG: SMPP PDU 0x99a76f0 dump:
> 2010-10-18 11:06:20 [6827] [6] DEBUG:   type_name: enquire_link_resp
> 2010-10-18 11:06:20 [6827] [6] DEBUG:   command_id: 2147483669 = 0x80000015
> 2010-10-18 11:06:20 [6827] [6] DEBUG:   command_status: 0 = 0x00000000
> 2010-10-18 11:06:20 [6827] [6] DEBUG:   sequence_number: 1867 = 0x0000074b
> 2010-10-18 11:06:20 [6827] [6] DEBUG: SMPP PDU dump ends.
> 2010-10-18 11:06:50 [6827] [6] DEBUG: SMPP[SMPP:*:5019/5019:mail:test]: Sending enquire link:
> 2010-10-18 11:06:50 [6827] [6] DEBUG: SMPP PDU 0x99a76f0 dump:
> 2010-10-18 11:06:50 [6827] [6] DEBUG:   type_name: enquire_link
> 2010-10-18 11:06:50 [6827] [6] DEBUG:   command_id: 21 = 0x00000015
> 2010-10-18 11:06:50 [6827] [6] DEBUG:   command_status: 0 = 0x00000000
> 2010-10-18 11:06:50 [6827] [6] DEBUG:   sequence_number: 1868 = 0x0000074c
> 2010-10-18 11:06:50 [6827] [6] DEBUG: SMPP PDU dump ends.
> 2010-10-18 11:06:50 [6827] [6] DEBUG: SMPP[SMPP:*:5019/5019:mail:test]: Got PDU:
> 2010-10-18 11:06:50 [6827] [6] DEBUG: SMPP PDU 0x99a76f0 dump:
> 2010-10-18 11:06:50 [6827] [6] DEBUG:   type_name: enquire_link_resp
> 2010-10-18 11:06:50 [6827] [6] DEBUG:   command_id: 2147483669 = 0x80000015
> 2010-10-18 11:06:50 [6827] [6] DEBUG:   command_status: 0 = 0x00000000
> 2010-10-18 11:06:50 [6827] [6] DEBUG:   sequence_number: 1868 = 0x0000074c
> 2010-10-18 11:06:50 [6827] [6] DEBUG: SMPP PDU dump ends.
> 2010-10-18 11:07:20 [6827] [6] DEBUG: SMPP[SMPP:*:5019/5019:mail:test]: Sending enquire link:
> 2010-10-18 11:07:20 [6827] [6] DEBUG: SMPP PDU 0x99a76f0 dump:
> 2010-10-18 11:07:20 [6827] [6] DEBUG:   type_name: enquire_link
> 2010-10-18 11:07:20 [6827] [6] DEBUG:   command_id: 21 = 0x00000015
> 2010-10-18 11:07:20 [6827] [6] DEBUG:   command_status: 0 = 0x00000000
> 2010-10-18 11:07:20 [6827] [6] DEBUG:   sequence_number: 1869 = 0x0000074d
> 2010-10-18 11:07:20 [6827] [6] DEBUG: SMPP PDU dump ends.
> 2010-10-18 11:07:20 [6827] [6] DEBUG: SMPP[SMPP:*:5019/5019:mail:test]: Got PDU:
> 2010-10-18 11:07:20 [6827] [6] DEBUG: SMPP PDU 0x99a76f0 dump:
> 2010-10-18 11:07:20 [6827] [6] DEBUG:   type_name: enquire_link_resp
> 2010-10-18 11:07:20 [6827] [6] DEBUG:   command_id: 2147483669 = 0x80000015
> 2010-10-18 11:07:20 [6827] [6] DEBUG:   command_status: 0 = 0x00000000
> 2010-10-18 11:07:20 [6827] [6] DEBUG:   sequence_number: 1869 = 0x0000074d
> 2010-10-18 11:07:20 [6827] [6] DEBUG: SMPP PDU dump ends.
> 
> 
> and can anyone confirm that is problem from vendor side . 
> 
> 
> On Mon, Oct 18, 2010 at 10:46 AM, Benaiad <benaiad at gmail.com> wrote:
> Hi Saeed,
> 
> Which operator returns this error, and when did you see this error, during register or submitting an sms?
> Post your configurations and part of your log which related to the problem.
> On Oct 18, 2010 10:22 AM, "Saeed Ashour" <libyano at gmail.com> wrote:
> 
> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.kannel.org/pipermail/devel/attachments/20101018/6afa0d7a/attachment-0001.html>


More information about the devel mailing list